Packages
Browse packages indexed by the registry.
Binary blobs with intelligent serialization
A base 64 encoding and decoding library for Rust.
A CLI tool for base64
encodes and decodes base64 as bytes or utf8 - compatible with older Rust versions
Base64 encode/decode with const-friendly decode and URL-safe macros
encode and decode use base64
Convert string to emoji cipher. Inspired by base64-emoji-parser
Base64 encryption and decryption
A base64 encoder / decoder
A basic base64 literal macro
no_std-first Base64 encoding and decoding with strict RFC 4648 APIs and optional SIMD
Optional bytes::Buf and Bytes helpers for base64-ng
dependency-free derive helpers for fixed-size base64-ng byte newtypes
Bounded RFC 3501 modified-Base64 payload transforms for base64-ng
Bounded RFC 2045 Base64 content-transfer body support for base64-ng
Bounded Base64-family multibase support for base64-ng
Bounded RFC 9580 OpenPGP ASCII armor support for base64-ng
Bounded Passlib PBKDF2 and SHA-crypt Base64 record transforms
Bounded RFC 7468 textual encoding support for base64-ng
Optional sanitization integration helpers for base64-ng
Optional serde wrappers for base64-ng
Optional subtle::ConstantTimeEq helpers for base64-ng buffers
Optional Tokio async helpers for base64-ng
A library for encoding binary data in base64 format according to rfc4648, and decoding it.
Base64 encoder/decoder with custom alphabet. The alphabet is sorted by a given key. The sorting is always deterministic.
Integration between rust-base64 and serde
SIMD-accelerated base64 encoding and decoding
To encode/decode large data with the standard Base64 encoding.
Implementation of the Base64 hash made using Rust
A Rust crate for base64 string
A Base64 engine that peaks past 100 GiB/s, formally verified (Kani/MIRI/MSan).
Base64 encode, decode, escape and unescape for URL applications.
Encode and decode images to and from base64
Base64 Encoder & Decoder
Fast, efficient, correct, and const base64 with padding encoding and decoding
A Base64 type based on the base64 crate that guarantees successful encoding and decoding.
A CLI tool for encoding and decoding Base64 strings
Simple Rust type wrapper for Vec<u8> that uses base64 for serialization
Pure Rust implementation of Base64 (RFC 4648) which avoids any usages of data-dependent branches/LUTs and thereby provides portable "best effort" constant-time operation and embedded-friendly no_std support
simple encodes and decodes base64 as bytes or utf8
Efficiently represent 64, 32 and 16 bit integers as base64url strings
Derive macro for base64id. Not intended for use directly.
Base64 encode and decode files