Packages
Browse packages indexed by the registry.
Compact Base58 UUID Encoder CLI - Convert UUIDs to 22-character Base58 format
Fast and secure Base64 encoding/decoding. This crate provides an implementation of Base64 encoding/decoding that is designed to be resistant against software side-channel attacks (such as timing & cache attacks), see the documentation for details. On certain platforms it also uses SIMD making it very fast. This makes it suitable for e.g. decoding cryptographic private keys in PEM format. The API is very similar to the base64 implementation in the old rustc-serialize crate, making it easy to use in existing projects.
Pure Rust implementation of B64, a subset of the standard Base64 encoding (RFC 4648) used by the PHC string format. Implemented without data-dependent branches or lookup tables providing "best effort" constant-time operation.
Cross-platform hardware-accelerated video/audio codecs (WebCodecs, MediaCodec, VAAPI, VideoToolbox)
Simple crate to derive a new file name from a source file name.
A fun game where you guess what number the computer has chosen.
Display and composition crate for virtio
Procedural macros for the babar PostgreSQL driver.
Universal CLI utility for Babbel polyglot serialization, querying, diffing, patching, and formatting
Fast, pure-Rust Apache Avro binary and Object Container File (OCF) parser, serializer, and FormatEngine
Fast, binary-safe BitTorrent Bencode parser, serializer, and DOM in pure Rust
Fast, binary-safe BSON (Binary JSON) parser, serializer, and FormatEngine in pure Rust
Fast, binary-safe RFC 8949 CBOR parser, serializer, and FormatEngine in pure Rust
Shared core I/O, encoding, numeric, error, and AST primitives for the Babbel data format family
Fast, pure-Rust HCL (HashiCorp Configuration Language v2) parser, serializer, and FormatEngine
Fast, modular JSON toolkit with streaming parsers, JSON Pointer (RFC 6901), and Merge Patch
Fast, pure-Rust KDL (KDL Document Language) parser, serializer, and FormatEngine
Fast, binary-safe MessagePack parser, serializer, and FormatEngine in pure Rust
Fast, pure-Rust Apache Parquet columnar reader, writer, and FormatEngine
Fast, pure-Rust RON (Rusty Object Notation) parser, serializer, and FormatEngine
Fast, pure-Rust, zero-allocation TOML v1.0.0 parser, serializer, streaming pull parser, and DOM
Full-featured XML parser, validator, stringifier, and XPath 1.0 engine in pure Rust